La última… Debian Squeeze no carga sin monitor conectado

Recientemente actualicé el servidorcillo que tengo en casa con Debian a Squeeze. Como veía que no arrancaba bien, le conecté un monitor, y al ver que en los varios reinicios que hice de prueba todo cargaba correctamente… pues lo di por bueno sin más.

Anteayer de madrugada cortaron la corriente en parte de mi calle. Cuando yo ya estaba durmiendo plácidamente, a eso de las 12.00 los dos SAIs que tengo en casa comenzaron a pitar, así que me levanté con un ojo cerrado y el otro medio abierto y apagué ambos de «botonazo», dejando sin corriente también el servidor que colgaba de uno de ellos.

A la mañana, al encenderlo, vi que no arrancaba. Lo saqué de detrás del sofá, me lo llevé a mi habitación, y le conecté monitor y teclado. Extrañamente todo cargaba bien de nuevo… lo reinicié, funcionó, lo volví a reiniciar, y volvió a cargar todo correctamente… Extraño, pero bueno… lo llevé de nuevo a su lugar habitual (detrás de un sofá -que ya de paso, insonoriza-, en una habitación que normalmente no usa nadie) y nuevamente volvió a fallar… eso me llevó a pensar que tenía que ser algo que hay conectado aquí y en mi habitación no, así que desconecté tanto el SAI conectado por USB como el receptor de teclado-ratón inalámbrico por PS/2 y el resultado fue el mismo. Al final desmonté un monitor y lo llevé hasta ahí, para ver nuevamente como arrancaba correctamente.

Definitivamente el problema estaba en el monitor. Vamos, que sin monitor no llegaba a arrancar. Si conectaba el monitor habiendo arrancado sin él, únicamente se veía la pantalla en negro, y por muchas teclas que pulsases todo seguía igual.

Tras una pequeña indagación desde el propio servidor utilizando elinks llegué hasta una entrada del wiki de Debian (http://wiki.debian.org/KernelModesetting) en la que explicaban que en Squeeze el KernelModeSetting (KMS) viene activado por defecto. Se trata de una mejora de velocidad a la hora de pasar entre X y consola. Como las X las tengo únicamente instaladas para acceder por VNC, realmente es algo de lo que puedo prescindir, así que en esa misma página te explican cómo hacerlo.

En mi caso, al tener una gráfica integrada Intel 915, es tal que así:

  • Editamos el /etc/default/grub.conf y en la línea de GRUB_CMDLINE_LINUX_DEFAULT añadimos «nomodeset».
  • Ejecutamos update-grub para aplicar los cambios.
  • Edita el fichero /etc/modprobe.d/i915-kms.conf y cambia el modeset de 1 a 0.
  • Reinicia con el monitor desconectado y comprueba que todo ha ido bien 🙂
Si tienes una gráfica distinta, en el wiki especificado más arriba tienes los pasos a seguir.
Espero que te sea de ayuda.
Suerte!
¿Te ha parecido interesante? ¡Compártelo! --> Facebooktwitterlinkedinmail

 

2 pensamientos en “La última… Debian Squeeze no carga sin monitor conectado

Responder a Jhon Ramirez Cancelar respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.